ESP32 no Windows

  • Instalar o Python a versão mais recente disponível em https://www.python.org/downloads/
  • Adicionar o Python ao path do windows. No momento da instalação tem uma opção para isso.
  • Instalar o driver CP2102 disponível em https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
  • Instalar o utilitário Esptool no Python, executando no CMD do windows o seguinte comando: 
    • pip install esptool
  • Com o NodeMCU conectado ao computador, é preciso "formata-lo" com o seguinte comando no CMD, onde o COM3 do comando deve ser a porta craida pelo driver instalado anteriormente:
    • esptool.py --port COM3 erase_flash
  • Obter a versão mais recente do firmware do NodeMCU em https://nodemcu-build.com/
  • Instalar o firmware no NodeMCU com o seguinte comando:
    • esptool.py --chip esp32 --port COM3 write_flash --flash_mode dio --flash_size detect 0x00000 nodemmcu-master.bin
  • Instalar o software Arduino disponível em https://www.arduino.cc/en/Main/Software
    • Executar o Arduino e realizar a seguinte configuração:

      1. Acessar File> Preferences

        Installing ESP32 Add-on in Arduino IDE Windows, Mac OS X, Linux open preferences
      2. adicionar a URL https://dl.espressif.com/dl/package_esp32_index.json no campo “Additional Board Manager URLs” e clicar no botão “OK”:

        Installing ESP32 Add-on in Arduino IDE Windows, Mac OS X, Linux enter URLs

        Nota: Caso já tenha configurado a URL do ESP8266 basta adicionar virgula e depois a URL do ESP32:

        https://dl.espressif.com/dl/package_esp32_index.json, http://arduino.esp8266.com/stable/package_esp8266com_index.json
      3. Abrir o Boards Manager no menu Tools > Board > Boards Manager…

        Installing ESP32 Add-on in Arduino IDE Windows, Mac OS X, Linux open boards manager
      4. Buscar por ESP32 e clicar no botão "Install" da opção “ESP32 by Espressif Systems“:

        ESP32 Add-on in Arduino IDE Windows, Mac OS X, Linux Installed
      5. No menu Tools > Board selecionar a opção "ESP32 DEV Module"

      6. Com o NodeMCU ESP32 conectado ao computador via USB, selecione em Tools > Port selecionar a porta COM gerada para ele.

  • Assim é possível abrir os arquivos .ino com o programa a ser executado pelo NodeMCU e carrega-los na placa através do botão Load